What’s Vulnerable › Vulnerabilities
CVE-2019-15552
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-08-26 · updated 2026-06-17
- Weakness: CWE-416
Description
An issue was discovered in the libflate crate before 0.1.25 for Rust. MultiDecoder::read has a use-after-free, leading to arbitrary code execution.
Affected products
- Libflate Project Libflate: from 0.1.14 before 0.1.25 — fixed in 0.1.25
How to fix
Upgrade to a fixed version: Libflate Project Libflate 0.1.25. Check the vendor advisory for mitigations.
References
- https://github.com/sile/libflate/issues/35
- https://rustsec.org/advisories/RUSTSEC-2019-0010.html
- https://github.com/sile/libflate/issues/35
- https://rustsec.org/advisories/RUSTSEC-2019-0010.html
Get alerted when CVE-2019-15552 or the next vulnerability affects your stack