What’s Vulnerable › Vulnerabilities
CVE-2019-15580
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-12-18 · updated 2026-06-17
- Weakness: CWE-201
Description
An information exposure vulnerability exists in gitlab.com <v12.3.2, <v12.2.6, and <v12.1.10 when using the blocking merge request feature, it was possible for an unauthenticated user to see the head pipeline data of a public project even though pipeline visibility was restricted.
Affected products
- GitLab: before 12.1.10; from 12.2.0 before 12.2.6; from 12.3.0 before 12.3.2 — fixed in 12.1.10, 12.2.6, 12.3.2
How to fix
Upgrade to a fixed version: GitLab 12.1.10, 12.2.6, 12.3.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2019-15580 or the next vulnerability affects your stack