What’s Vulnerable › Vulnerabilities
CVE-2019-15584
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-12-20 · updated 2026-06-17
- Weakness: CWE-400
Description
A denial of service exists in gitlab <v12.3.2, <v12.2.6, and <v12.1.10 that would let an attacker bypass input validation in markdown fields take down the affected page.
Affected products
- GitLab: before 12.1.10; from 12.2.0 before 12.2.6; from 12.3.0 before 12.3.2 — fixed in 12.1.10, 12.2.6, 12.3.2
How to fix
Upgrade to a fixed version: GitLab 12.1.10, 12.2.6, 12.3.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2019-15584 or the next vulnerability affects your stack