What’s Vulnerable › Vulnerabilities
CVE-2019-15585
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-01-28 · updated 2026-06-17
- Weakness: CWE-287
Description
Improper authentication exists in < 12.3.2, < 12.2.6, and < 12.1.12 for GitLab Community Edition (CE) and Enterprise Edition (EE) in the GitLab SAML integration had a validation issue that permitted an attacker to takeover another user's account.
Affected products
- GitLab: from 12.1.0 before 12.1.12; from 12.2.0 before 12.2.6; from 12.3.0 before 12.3.2 — fixed in 12.1.12, 12.2.6, 12.3.2
How to fix
Upgrade to a fixed version: GitLab 12.1.12, 12.2.6, 12.3.2. Check the vendor advisory for mitigations.
References
- https://about.gitlab.com/blog/2019/09/30/security-release-gitlab-12-dot-3-dot-2-released/
- https://hackerone.com/reports/471323
- https://about.gitlab.com/blog/2019/09/30/security-release-gitlab-12-dot-3-dot-2-released/
- https://hackerone.com/reports/471323
Get alerted when CVE-2019-15585 or the next vulnerability affects your stack