What’s Vulnerable › Vulnerabilities
CVE-2019-15587: Loofah Allows Cross-site Scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-10-22 · updated 2026-06-17
- Weakness: CWE-79
Description
In the Loofah gem for Ruby through v2.3.0 unsanitized JavaScript may occur in sanitized output when a crafted SVG element is republished.
Affected products
- Canonical Ubuntu Linux: 16.04
- Debian Linux: 9.0, 10.0
- Fedoraproject Fedora: 30, 31
- flavorjones loofah: through 2.3.0
- Rubygems Loofah: before 2.3.1; 0.2.0, 0.2.1, 0.2.2, 0.3.0, 0.3.1, 0.4.0 (+25) — fixed in 2.3.1
How to fix
Upgrade to a fixed version: Rubygems Loofah 2.3.1. Check the vendor advisory for mitigations.
References
- https://github.com/flavorjones/loofah/issues/171
- https://hackerone.com/reports/709009
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/4WK2UG7ORKRQOJ6E4XJ2NVIHYJES6BYZ/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/XMCWPLYPNIWYAY443IZZJ4IHBBLIHBP5/
- https://security.netapp.com/advisory/ntap-20191122-0003/
- https://usn.ubuntu.com/4498-1/
- https://www.debian.org/security/2019/dsa-4554
- https://github.com/flavorjones/loofah/issues/171
- https://hackerone.com/reports/709009
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/4WK2UG7ORKRQOJ6E4XJ2NVIHYJES6BYZ/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/XMCWPLYPNIWYAY443IZZJ4IHBBLIHBP5/
- https://security.netapp.com/advisory/ntap-20191122-0003/
Get alerted when CVE-2019-15587 or the next vulnerability affects your stack