What’s Vulnerable › Vulnerabilities
CVE-2019-15589
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-12-18 · updated 2026-06-17
- Weakness: CWE-284
Description
An improper access control vulnerability exists in Gitlab <v12.3.2, <v12.2.6, <v12.1.12 which would allow a blocked user would be able to use GIT clone and pull if he had obtained a CI/CD token before.
Affected products
- GitLab: before 12.1.12; from 12.2.0 before 12.2.6; from 12.3.0 before 12.3.2 — fixed in 12.1.12, 12.2.6, 12.3.2
How to fix
Upgrade to a fixed version: GitLab 12.1.12, 12.2.6, 12.3.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2019-15589 or the next vulnerability affects your stack