What’s Vulnerable › Vulnerabilities
CVE-2019-1559: 0-byte record padding oracle
- Severity: medium (CVSS 5.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 17.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-02-27 · updated 2026-06-17
- Weakness: CWE-203
Description
If an application encounters a fatal protocol error and then calls SSL_shutdown() twice (once to send a close_notify, and once to receive one) then OpenSSL can respond differently to the calling application if a 0 byte record is received with invalid padding compared to if a 0 byte record is received with an invalid MAC. If the application then behaves differently based on that in a way that is detectable to the remote peer, then this amounts to a padding oracle that could be used to decrypt data. In order for this to be exploitable "non-stitched" ciphersuites must be in use. Stitched ciphersuites are optimised implementations of certain commonly used ciphersuites. Also the application must call SSL_shutdown() twice even if a protocol error has occurred (applications should not do this but some do anyway). Fixed in OpenSSL 1.0.2r (Affected 1.0.2-1.0.2q).
Affected products
- Canonical Ubuntu Linux: 16.04, 18.04, 18.10
- Debian Linux: 8.0, 9.0
- F5 BIG-IP APM: from 12.1.0 through 12.1.5; from 13.0.0 through 13.1.3; from 14.0.0 through 14.1.2; from 15.0.0 through 15.1.0
- BIG-IP: from 12.1.0 through 12.1.5; from 13.0.0 through 13.1.3; from 14.0.0 through 14.1.2; from 15.0.0 through 15.1.0
- F5 Big-Ip Analytics: from 12.1.0 through 12.1.5; from 13.0.0 through 13.1.3; from 14.0.0 through 14.1.2; from 15.0.0 through 15.1.0
- F5 Networks, Inc. BIG-IP (AAM): from 12.1.0 through 12.1.5; from 13.0.0 through 13.1.3; from 14.0.0 through 14.1.2; from 15.0.0 through 15.1.0
- BIG-IP ASM: from 12.1.0 through 12.1.5; from 13.0.0 through 13.1.3; from 14.0.0 through 14.1.2; from 15.0.0 through 15.1.0
- F5 BIG-IP DNS: from 12.1.0 through 12.1.5; from 13.0.0 through 13.1.3; from 14.0.0 through 14.1.2; from 15.0.0 through 15.1.0
- F5 Big-Ip Edge Gateway: from 12.1.0 through 12.1.5; from 13.0.0 through 13.1.3; from 14.0.0 through 14.1.2; from 15.0.0 through 15.1.0
- F5 Big-Ip Fraud Protection Service: from 12.1.0 through 12.1.5; from 13.0.0 through 13.1.3; from 14.0.0 through 14.1.2; from 15.0.0 through 15.1.0
- F5 Big-Ip Global Traffic Manager: from 12.1.0 through 12.1.5; from 13.0.0 through 13.1.3; from 14.0.0 through 14.1.2; from 15.0.0 through 15.1.0
- F5 Big-Ip Link Controller: from 12.1.0 through 12.1.5; from 13.0.0 through 13.1.3; from 14.0.0 through 14.1.2; from 15.0.0 through 15.1.0
- F5 BIG-IP (LTM): from 12.1.0 through 12.1.5; from 13.0.0 through 13.1.3; from 14.0.0 through 14.1.2; from 15.0.0 through 15.1.0
- F5 Networks, Inc. BIG-IP (PEM): from 12.1.0 through 12.1.5; from 13.0.0 through 13.1.3; from 14.0.0 through 14.1.2; from 15.0.0 through 15.1.0
- F5 Big-Ip Webaccelerator: from 12.1.0 through 12.1.5; from 13.0.0 through 13.1.3; from 14.0.0 through 14.1.2; from 15.0.0 through 15.1.0
- F5 BIG-IQ: from 6.0.0 through 6.1.0; from 7.0.0 through 7.1.0
- F5 Traffix SDC: from 5.0.0 through 5.1.0; 4.4.0
- Fedoraproject Fedora: 29, 30, 31
- McAfee,LLC McAfee Agent for Windows: from 5.6.0 through 5.6.4
- McAfee, LLC Data Exchange Layer (DXL) Broker: from 4.0.0 before 6.0.0 — fixed in 6.0.0
- McAfee,LLC Threat Intelligence Exchange Server (TIE Server): from 2.0.0 before 3.0.0 — fixed in 3.0.0
- McAfee Web Gateway (MWG): from 7.0.0 before 9.0.0 — fixed in 9.0.0
- NetApp A220 Firmware: all versions
- NetApp A320 Firmware: all versions
- NetApp A800 Firmware: all versions
- Active IQ Unified Manager for VMware vSphere, Linux, and Microsoft Windows: from 7.3; from 9.5
- NetApp Altavault: all versions
- NetApp C190 Firmware: all versions
- NetApp Cloud Backup: all versions
- NetApp Clustered Data Ontap Antivirus Connector: all versions
How to fix
Upgrade to a fixed version: McAfee, LLC Data Exchange Layer (DXL) Broker 6.0.0; McAfee,LLC Threat Intelligence Exchange Server (TIE Server) 3.0.0; McAfee Web Gateway (MWG) 9.0.0; Node.js 6.17.0, 8.15.1; OpenSSL 1.0.2r. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2019-03/msg00041.html
- http://lists.opensuse.org/opensuse-security-announce/2019-04/msg00019.html
- http://lists.opensuse.org/opensuse-security-announce/2019-04/msg00046.html
- http://lists.opensuse.org/opensuse-security-announce/2019-04/msg00047.html
- http://lists.opensuse.org/opensuse-security-announce/2019-05/msg00049.html
- http://lists.opensuse.org/opensuse-security-announce/2019-06/msg00080.html
- http://www.securityfocus.com/bid/107174
- https://access.redhat.com/errata/RHSA-2019:2304
- https://access.redhat.com/errata/RHSA-2019:2437
- https://access.redhat.com/errata/RHSA-2019:2439
- https://access.redhat.com/errata/RHSA-2019:2471
- https://access.redhat.com/errata/RHSA-2019:3929
Get alerted when CVE-2019-1559 or the next vulnerability affects your stack