What’s Vulnerable › Vulnerabilities
CVE-2019-15590
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-01-28 · updated 2026-06-17
- Weakness: CWE-284
Description
An access control issue exists in < 12.3.5, < 12.2.8, and < 12.1.14 for GitLab Community Edition (CE) and Enterprise Edition (EE) where private merge requests and issues would be disclosed with the Group Search feature provided by Elasticsearch integration
Affected products
- GitLab: from 12.1.0 before 12.1.14; from 12.2.0 before 12.2.8; from 12.3.0 before 12.3.5 — fixed in 12.1.14, 12.2.8, 12.3.5
How to fix
Upgrade to a fixed version: GitLab 12.1.14, 12.2.8, 12.3.5. Check the vendor advisory for mitigations.
References
- https://about.gitlab.com/releases/2019/10/07/security-release-gitlab-12-dot-3-dot-5-released/
- https://hackerone.com/reports/701144
- https://about.gitlab.com/releases/2019/10/07/security-release-gitlab-12-dot-3-dot-5-released/
- https://hackerone.com/reports/701144
Get alerted when CVE-2019-15590 or the next vulnerability affects your stack