What’s Vulnerable › Vulnerabilities
CVE-2019-15591
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-12-18 · updated 2026-06-17
- Weakness: CWE-284
Description
An improper access control vulnerability exists in GitLab <12.3.3 that allows an attacker to obtain container and dependency scanning reports through the merge request widget even though public pipelines were disabled.
Affected products
- GitLab: before 12.3.3 — fixed in 12.3.3
How to fix
Upgrade to a fixed version: GitLab 12.3.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2019-15591 or the next vulnerability affects your stack