What’s Vulnerable › Vulnerabilities
CVE-2019-15608
- Severity: medium (CVSS 5.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-03-15 · updated 2026-06-17
- Weakness: CWE-840
Description
The package integrity validation in yarn < 1.19.0 contains a TOCTOU vulnerability where the hash is computed before writing a package to cache. It's not computed again when reading from the cache. This may lead to a cache pollution attack.
Affected products
- yarn: before 1.19.0 — fixed in 1.19.0
How to fix
Upgrade to a fixed version: yarn 1.19.0. Check the vendor advisory for mitigations.
References
- https://github.com/yarnpkg/yarn/blob/master/CHANGELOG.md#1190
- https://github.com/yarnpkg/yarn/commit/0474b8c66a8ea298f5e4dedc67b2de464297ad1c
- https://hackerone.com/reports/703138
- https://github.com/yarnpkg/yarn/blob/master/CHANGELOG.md#1190
- https://github.com/yarnpkg/yarn/commit/0474b8c66a8ea298f5e4dedc67b2de464297ad1c
- https://hackerone.com/reports/703138
Get alerted when CVE-2019-15608 or the next vulnerability affects your stack