What’s Vulnerable › Vulnerabilities
CVE-2019-15612
- Severity: medium (CVSS 5.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-02-04 · updated 2026-06-17
- Weakness: CWE-384
Description
A bug in Nextcloud Server 15.0.2 causes pending 2FA logins to not be correctly expired when the password of the user is reset.
Affected products
- Nextcloud Server: from 13.0.0 before 13.0.11; from 14.0.0 before 14.0.7; from 15.0.0 before 15.0.3 — fixed in 13.0.11, 14.0.7, 15.0.3
How to fix
Upgrade to a fixed version: Nextcloud Server 13.0.11, 14.0.7, 15.0.3. Check the vendor advisory for mitigations.
References
- https://hackerone.com/reports/486693
- https://nextcloud.com/security/advisory/?id=NC-SA-2020-001
- https://hackerone.com/reports/486693
- https://nextcloud.com/security/advisory/?id=NC-SA-2020-001
Get alerted when CVE-2019-15612 or the next vulnerability affects your stack