What’s Vulnerable › Vulnerabilities
CVE-2019-15618
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-02-04 · updated 2026-06-17
- Weakness: CWE-79
Description
Missing escaping of HTML in the Updater of Nextcloud 15.0.5 allowed a reflected XSS when starting the updater from a malicious location.
Affected products
- Nextcloud Server: before 14.0.9; from 15.0.0 before 15.0.6 — fixed in 14.0.9, 15.0.6
How to fix
Upgrade to a fixed version: Nextcloud Server 14.0.9, 15.0.6. Check the vendor advisory for mitigations.
References
- https://hackerone.com/reports/515484
- https://nextcloud.com/security/advisory/?id=NC-SA-2020-007
- https://hackerone.com/reports/515484
- https://nextcloud.com/security/advisory/?id=NC-SA-2020-007
Get alerted when CVE-2019-15618 or the next vulnerability affects your stack