What’s Vulnerable › Vulnerabilities
CVE-2019-15624
- Severity: medium (CVSS 4.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-02-04 · updated 2026-06-17
- Weakness: CWE-20
Description
Improper Input Validation in Nextcloud Server 15.0.7 allows group admins to create users with IDs of system folders.
Affected products
- Nextcloud Server: before 14.0.11; from 15.0.0 before 15.0.8 — fixed in 14.0.11, 15.0.8
- openSUSE Backports: sle-15-sp1
- SUSE Linux Enterprise: 12
How to fix
Upgrade to a fixed version: Nextcloud Server 14.0.11, 15.0.8. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2020-02/msg00019.html
- http://lists.opensuse.org/opensuse-security-announce/2020-02/msg00022.html
- https://hackerone.com/reports/508493
- https://nextcloud.com/security/advisory/?id=NC-SA-2019-015
- http://lists.opensuse.org/opensuse-security-announce/2020-02/msg00019.html
- http://lists.opensuse.org/opensuse-security-announce/2020-02/msg00022.html
- https://hackerone.com/reports/508493
- https://nextcloud.com/security/advisory/?id=NC-SA-2019-015
Get alerted when CVE-2019-15624 or the next vulnerability affects your stack