What’s Vulnerable › Vulnerabilities
CVE-2019-15640
- Severity: high (CVSS 7.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-08-26 · updated 2026-06-17
- Weakness: CWE-20
Description
Limesurvey before 3.17.10 does not validate both the MIME type and file extension of an image.
Affected products
- LimeSurvey: before 3.17.10 — fixed in 3.17.10
How to fix
Upgrade to a fixed version: LimeSurvey 3.17.10. Check the vendor advisory for mitigations.
References
- https://github.com/LimeSurvey/LimeSurvey/commit/0479e3ff93ff1473a25c71e83cc011920b072b4c#diff-d539f3f8185667ee48db78e1bf65a3b4R43
- https://github.com/LimeSurvey/LimeSurvey/commit/0479e3ff93ff1473a25c71e83cc011920b072b4c#diff-d539f3f8185667ee48db78e1bf65a3b4R43
Get alerted when CVE-2019-15640 or the next vulnerability affects your stack