What’s Vulnerable › Vulnerabilities
CVE-2019-15652
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-11-22 · updated 2026-06-17
- Weakness: CWE-79
Description
The web interface for NSSLGlobal SatLink VSAT Modem Unit (VMU) devices before 18.1.0 doesn't properly sanitize input for error messages, leading to the ability to inject client-side code.
Affected products
- Nssglobal Vmu Software: before 18.1.0 — fixed in 18.1.0
How to fix
Upgrade to a fixed version: Nssglobal Vmu Software 18.1.0. Check the vendor advisory for mitigations.
References
- https://www.trustwave.com/en-us/resources/blogs/spiderlabs-blog/cve-2019-15652-satlink-vsat-vulnerabilities/
- https://www.trustwave.com/en-us/resources/security-resources/security-advisories/?fid=26455
- https://www.trustwave.com/en-us/resources/blogs/spiderlabs-blog/cve-2019-15652-satlink-vsat-vulnerabilities/
- https://www.trustwave.com/en-us/resources/security-resources/security-advisories/?fid=26455
Get alerted when CVE-2019-15652 or the next vulnerability affects your stack