What’s Vulnerable › Vulnerabilities
CVE-2019-15657
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-08-26 · updated 2026-06-17
Description
In eslint-utils before 1.4.1, the getStaticValue function can execute arbitrary code.
Affected products
- Eslint-Utils Project Eslint-Utils: before 1.4.1 — fixed in 1.4.1
How to fix
Upgrade to a fixed version: Eslint-Utils Project Eslint-Utils 1.4.1. Check the vendor advisory for mitigations.
References
- https://github.com/mysticatea/eslint-utils/security/advisories/GHSA-3gx7-xhv7-5mx3
- https://github.com/mysticatea/eslint-utils/security/advisories/GHSA-3gx7-xhv7-5mx3
Get alerted when CVE-2019-15657 or the next vulnerability affects your stack