What’s Vulnerable › Vulnerabilities
CVE-2019-15658
- Severity: high (CVSS 7.3 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-08-26 · updated 2026-06-17
- Weakness: CWE-89
Description
connect-pg-simple before 6.0.1 allows SQL injection if tableName or schemaName is untrusted data.
Affected products
- Connect-Pg-Simple Project Connect-Pg-Simple: before 6.0.1 — fixed in 6.0.1
How to fix
Upgrade to a fixed version: Connect-Pg-Simple Project Connect-Pg-Simple 6.0.1. Check the vendor advisory for mitigations.
References
- https://github.com/voxpelli/node-connect-pg-simple/security/advisories/GHSA-xqh8-5j36-4556
- https://github.com/voxpelli/node-connect-pg-simple/security/advisories/GHSA-xqh8-5j36-4556
Get alerted when CVE-2019-15658 or the next vulnerability affects your stack