What’s Vulnerable › Vulnerabilities
CVE-2019-15715
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 30.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-10-09 · updated 2026-06-17
- Weakness: CWE-78
Description
MantisBT before 1.3.20 and 2.22.1 allows Post Authentication Command Injection, leading to Remote Code Execution.
Affected products
- mantisbt: from 1.0.0 before 1.3.20; from 2.0.0 before 2.22.1 — fixed in 1.3.20, 2.22.1
How to fix
Upgrade to a fixed version: mantisbt 1.3.20, 2.22.1. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/159219/Mantis-Bug-Tracker-2.3.0-Remote-Code-Execution.html
- https://github.com/mantisbt/mantisbt/commit/5fb979604d88c630343b3eaf2b435cd41918c501
- https://github.com/mantisbt/mantisbt/commit/7092573fac31eff41823f13540324db167c8bd52
- https://github.com/mantisbt/mantisbt/commit/cebfb9acb3686e8904d80bd4bc80720b54ba08e5
- https://github.com/mantisbt/mantisbt/commit/fc7668c8e45db55fc3a4b991ea99d2b80861a14c
- https://mantisbt.org/bugs/changelog_page.php?project=mantisbt
- https://mantisbt.org/bugs/view.php?id=26091
- https://mantisbt.org/bugs/view.php?id=26162
- http://packetstormsecurity.com/files/159219/Mantis-Bug-Tracker-2.3.0-Remote-Code-Execution.html
- https://github.com/mantisbt/mantisbt/commit/5fb979604d88c630343b3eaf2b435cd41918c501
- https://github.com/mantisbt/mantisbt/commit/7092573fac31eff41823f13540324db167c8bd52
- https://github.com/mantisbt/mantisbt/commit/cebfb9acb3686e8904d80bd4bc80720b54ba08e5
Get alerted when CVE-2019-15715 or the next vulnerability affects your stack