What’s Vulnerable › Vulnerabilities
CVE-2019-15716
- Severity: medium (CVSS 5.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-08-28 · updated 2026-06-17
- Weakness: CWE-276
Description
WTF before 0.19.0 does not set the permissions of config.yml, which might make it easier for local attackers to read passwords or API keys if the permissions were misconfigured or were based on unsafe OS defaults.
Affected products
- Wtfutil Wtf: before 0.19.0 — fixed in 0.19.0
How to fix
Upgrade to a fixed version: Wtfutil Wtf 0.19.0. Check the vendor advisory for mitigations.
References
- https://github.com/wtfutil/wtf/blob/67658e172c9470e93e4122d6e2c90d01db12b0ac/cfg/config_files.go#L71-L72
- https://github.com/wtfutil/wtf/compare/v0.18.0...v0.19.0
- https://github.com/wtfutil/wtf/issues/517
- https://github.com/wtfutil/wtf/blob/67658e172c9470e93e4122d6e2c90d01db12b0ac/cfg/config_files.go#L71-L72
- https://github.com/wtfutil/wtf/compare/v0.18.0...v0.19.0
- https://github.com/wtfutil/wtf/issues/517
Get alerted when CVE-2019-15716 or the next vulnerability affects your stack