What’s Vulnerable › Vulnerabilities
CVE-2019-15717
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-08-29 · updated 2026-06-17
- Weakness: CWE-416
Description
Irssi 1.2.x before 1.2.2 has a use-after-free if the IRC server sends a double CAP.
Affected products
- Canonical Ubuntu Linux: 19.04
- Irssi: from 1.2.0 before 1.2.2 — fixed in 1.2.2
How to fix
Upgrade to a fixed version: Irssi 1.2.2. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2019/08/29/3
- http://www.openwall.com/lists/oss-security/2019/08/29/5
- https://irssi.org/security/irssi_sa_2019_08.txt
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/JDDRTNKDDO52CO5USJ73BE6XVG7BD4KP/
- https://usn.ubuntu.com/4119-1/
- http://www.openwall.com/lists/oss-security/2019/08/29/3
- http://www.openwall.com/lists/oss-security/2019/08/29/5
- https://irssi.org/security/irssi_sa_2019_08.txt
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/JDDRTNKDDO52CO5USJ73BE6XVG7BD4KP/
- https://usn.ubuntu.com/4119-1/
Get alerted when CVE-2019-15717 or the next vulnerability affects your stack