What’s Vulnerable › Vulnerabilities
CVE-2019-15728
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-09-16 · updated 2026-06-17
- Weakness: CWE-918
Description
An issue was discovered in GitLab Community and Enterprise Edition 10.1 through 12.2.1. Protections against SSRF attacks on the Kubernetes integration are insufficient, which could have allowed an attacker to request any local network resource accessible from the GitLab server.
Affected products
- GitLab: from 10.1.0 before 12.0.8; from 12.1.0 before 12.1.8; from 12.2.0 before 12.2.3 — fixed in 12.0.8, 12.1.8, 12.2.3
How to fix
Upgrade to a fixed version: GitLab 12.0.8, 12.1.8, 12.2.3. Check the vendor advisory for mitigations.
References
- https://about.gitlab.com/2019/08/29/security-release-gitlab-12-dot-2-dot-3-released/
- https://gitlab.com/gitlab-org/gitlab-ce/issues/61314
- https://about.gitlab.com/2019/08/29/security-release-gitlab-12-dot-2-dot-3-released/
- https://gitlab.com/gitlab-org/gitlab-ce/issues/61314
Get alerted when CVE-2019-15728 or the next vulnerability affects your stack