What’s Vulnerable › Vulnerabilities
CVE-2019-15741
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-09-16 · updated 2026-06-17
Description
An issue was discovered in GitLab Omnibus 7.4 through 12.2.1. An unsafe interaction with logrotate could result in a privilege escalation
Affected products
- GitLab Omnibus: from 7.4.0 before 12.0.8; from 12.1.0 before 12.1.8; from 12.2.0 before 12.2.3 — fixed in 12.0.8, 12.1.8, 12.2.3
How to fix
Upgrade to a fixed version: GitLab Omnibus 12.0.8, 12.1.8, 12.2.3. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/154734/GitLab-Omnibus-12.2.1-Logrotate-Privilege-Escalation.html
- http://seclists.org/fulldisclosure/2019/Oct/7
- https://about.gitlab.com/2019/08/29/security-release-gitlab-12-dot-2-dot-3-released/
- https://gitlab.com/gitlab-org/omnibus-gitlab/issues/4380
- http://packetstormsecurity.com/files/154734/GitLab-Omnibus-12.2.1-Logrotate-Privilege-Escalation.html
- http://seclists.org/fulldisclosure/2019/Oct/7
- https://about.gitlab.com/2019/08/29/security-release-gitlab-12-dot-2-dot-3-released/
- https://gitlab.com/gitlab-org/omnibus-gitlab/issues/4380
Get alerted when CVE-2019-15741 or the next vulnerability affects your stack