What’s Vulnerable › Vulnerabilities
CVE-2019-1575
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-07-16 · updated 2026-06-17
- Weakness: CWE-200
Description
Information disclosure in PAN-OS 7.1.23 and earlier, PAN-OS 8.0.18 and earlier, PAN-OS 8.1.8-h4 and earlier, and PAN-OS 9.0.2 and earlier may allow for an authenticated user with read-only privileges to extract the API key of the device and/or the username/password from the XML API (in PAN-OS) and possibly escalate privileges granted to them.
Affected products
- Palo Alto Networks PAN-OS: before 7.1.24; from 8.0.0 before 8.0.19; from 8.1.0 before 8.1.8; from 9.0.0 through 9.0.2; 8.1.8-h4; 8.1.8 — fixed in 7.1.24, 8.0.19, 8.1.8
- Palo Alto Networks PAN-OS: through PAN-OS 7.1.23; through PAN-OS 8.0.18; through PAN-OS 8.1.8-h4; and PAN-OS 9.0.2-h3
How to fix
Upgrade to a fixed version: Palo Alto Networks PAN-OS 7.1.24, 8.0.19, 8.1.8. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/109176
- https://security.paloaltonetworks.com/CVE-2019-1575
- http://www.securityfocus.com/bid/109176
- https://security.paloaltonetworks.com/CVE-2019-1575
Get alerted when CVE-2019-1575 or the next vulnerability affects your stack