What’s Vulnerable › Vulnerabilities
CVE-2019-15771
- Severity: medium (CVSS 6.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-08-29 · updated 2026-06-17
- Weakness: CWE-601
Description
The nd-shortcodes plugin before 6.0 for WordPress has a nopriv_ AJAX action that allows modification of the siteurl setting.
Affected products
- Components For Wp Bakery Page Builder Project Components For Wp Bakery Page Builder: before 6.0 — fixed in 6.0
How to fix
Upgrade to a fixed version: Components For Wp Bakery Page Builder Project Components For Wp Bakery Page Builder 6.0. Check the vendor advisory for mitigations.
References
- https://threatpost.com/wordpress-plugins-exploited-in-ongoing-attack-researchers-warn/147671/
- https://wordpress.org/plugins/nd-shortcodes/#developers
- https://wpvulndb.com/vulnerabilities/9485
- https://threatpost.com/wordpress-plugins-exploited-in-ongoing-attack-researchers-warn/147671/
- https://wordpress.org/plugins/nd-shortcodes/#developers
- https://wpvulndb.com/vulnerabilities/9485
Get alerted when CVE-2019-15771 or the next vulnerability affects your stack