What’s Vulnerable › Vulnerabilities
CVE-2019-15777
- Severity: medium (CVSS 5.4 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-08-29 · updated 2026-06-17
- Weakness: CWE-79
Description
The shapepress-dsgvo plugin before 2.2.19 for WordPress has wp-admin/admin-ajax.php?action=admin-common-settings&admin_email= XSS.
Affected products
- Shapepress Wp Dsgvo Tools: before 2.2.19 — fixed in 2.2.19
How to fix
Upgrade to a fixed version: Shapepress Wp Dsgvo Tools 2.2.19. Check the vendor advisory for mitigations.
References
- https://wordpress.org/plugins/shapepress-dsgvo/#developers
- https://wpvulndb.com/vulnerabilities/9850
- https://www.pluginvulnerabilities.com/2019/08/22/gdpr-plugins-for-wordpress-continue-to-be-insecure/
- https://wordpress.org/plugins/shapepress-dsgvo/#developers
- https://wpvulndb.com/vulnerabilities/9850
- https://www.pluginvulnerabilities.com/2019/08/22/gdpr-plugins-for-wordpress-continue-to-be-insecure/
Get alerted when CVE-2019-15777 or the next vulnerability affects your stack