What’s Vulnerable › Vulnerabilities
CVE-2019-15789: Microk8s Privilege Escalation Vulnerability
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-04-08 · updated 2026-06-17
- Weakness: CWE-269
Description
Privilege escalation vulnerability in MicroK8s allows a low privilege user with local access to obtain root access to the host by provisioning a privileged container. Fixed in MicroK8s 1.15.3.
Affected products
- Canonical MicroK8s: before 1.15.3 — fixed in 1.15.3
How to fix
Upgrade to a fixed version: Canonical MicroK8s 1.15.3. Check the vendor advisory for mitigations.
References
- https://discuss.kubernetes.io/t/explicit-use-of-sudo-in-microk8s-cli/7605
- https://github.com/ubuntu/microk8s/pull/590
- https://people.canonical.com/~ubuntu-security/cve/2019/CVE-2019-15789.html
- https://pulsesecurity.co.nz/advisories/microk8s-privilege-escalation
- https://discuss.kubernetes.io/t/explicit-use-of-sudo-in-microk8s-cli/7605
- https://github.com/ubuntu/microk8s/pull/590
- https://people.canonical.com/~ubuntu-security/cve/2019/CVE-2019-15789.html
- https://pulsesecurity.co.nz/advisories/microk8s-privilege-escalation
Get alerted when CVE-2019-15789 or the next vulnerability affects your stack