What’s Vulnerable › Vulnerabilities
CVE-2019-15795: python-apt uses MD5 for validation
- Severity: medium (CVSS 4.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-03-26 · updated 2026-06-17
- Weakness: CWE-327
Description
python-apt only checks the MD5 sums of downloaded files in `Version.fetch_binary()` and `Version.fetch_source()` of apt/package.py in version 1.9.0ubuntu1 and earlier. This allows a man-in-the-middle attack which could potentially be used to install altered packages and has been fixed in versions 1.9.0ubuntu1.2, 1.6.5ubuntu0.1, 1.1.0~beta1ubuntu0.16.04.7, 0.9.3.5ubuntu3+esm2, and 0.8.3ubuntu7.5.
Affected products
- Debian Python-Apt: 1.8.4
- Ubuntu Python-Apt: 0.8.0-ubuntu9, 0.8.1-ubuntu1, 0.8.3-ubuntu1, 0.8.3-ubuntu2, 0.8.3-ubuntu3, 0.8.3-ubuntu4 (+59)
References
- https://usn.ubuntu.com/4247-1/
- https://usn.ubuntu.com/4247-3/
- https://usn.ubuntu.com/4247-1/
- https://usn.ubuntu.com/4247-3/
Get alerted when CVE-2019-15795 or the next vulnerability affects your stack