What’s Vulnerable › Vulnerabilities
CVE-2019-1581: PAN-OS: Remote code execution vulnerability in the PAN-OS SSH device management interface
- Severity: high (CVSS 7.5 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-08-23 · updated 2026-06-17
- Weakness: CWE-78
Description
A remote code execution vulnerability in the PAN-OS SSH device management interface that can lead to unauthenticated remote users with network access to the SSH management interface gaining root access to PAN-OS. This issue affects PAN-OS 7.1 versions prior to 7.1.24-h1, 7.1.25; 8.0 versions prior to 8.0.19-h1, 8.0.20; 8.1 versions prior to 8.1.9-h4, 8.1.10; 9.0 versions prior to 9.0.3-h3, 9.0.4.
Affected products
- Palo Alto Networks PAN-OS: through 7.1.24; from 8.0.0 through 8.0.19; from 8.1.0 through 8.1.9; from 9.0.0 through 9.0.3
- Palo Alto Networks PAN-OS: from 7.1 before 7.1.24-h1, 7.1.25; from 8.0 before 8.0.19-h1, 8.0.20; from 8.1 before 8.1.9-h4, 8.1.10; from 9.0 before 9.0.3-h3, 9.0.4 — fixed in 7.1.24-h1, 7.1.25, 8.0.19-h1, 8.0.20, 8.1.9-h4, 8.1.10
How to fix
Upgrade to a fixed version: Palo Alto Networks PAN-OS 7.1.24-h1, 7.1.25, 8.0.19-h1, 8.0.20. Check the vendor advisory for mitigations.
References
- https://security.paloaltonetworks.com/CVE-2019-1581
- https://security.paloaltonetworks.com/CVE-2019-1581
Get alerted when CVE-2019-1581 or the next vulnerability affects your stack