What’s Vulnerable › Vulnerabilities
CVE-2019-15816
- Severity: high (CVSS 7.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-08-30 · updated 2026-06-17
- Weakness: CWE-79
Description
The wp-private-content-plus plugin before 2.0 for WordPress has no protection against option changes via save_settings_page and other save_ functions.
Affected products
- nimeshrmr WP Private Content Plus: before 2.0 — fixed in 2.0
How to fix
Upgrade to a fixed version: nimeshrmr WP Private Content Plus 2.0. Check the vendor advisory for mitigations.
References
- https://blog.nintechnet.com/unauthenticated-options-change-vulnerability-in-wordpress-wp-private-content-plus-plugin/
- https://wordpress.org/plugins/wp-private-content-plus/#developers
- https://wpvulndb.com/vulnerabilities/9817
- https://blog.nintechnet.com/unauthenticated-options-change-vulnerability-in-wordpress-wp-private-content-plus-plugin/
- https://wordpress.org/plugins/wp-private-content-plus/#developers
- https://wpvulndb.com/vulnerabilities/9817
Get alerted when CVE-2019-15816 or the next vulnerability affects your stack