What’s Vulnerable › Vulnerabilities
CVE-2019-15822
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-08-30 · updated 2026-06-17
- Weakness: CWE-22
Description
The wps-child-theme-generator plugin before 1.2 for WordPress has classes/helpers.php directory traversal.
Affected products
- Wpserveur Wps Child Theme Generator: before 1.2 — fixed in 1.2
How to fix
Upgrade to a fixed version: Wpserveur Wps Child Theme Generator 1.2. Check the vendor advisory for mitigations.
References
- https://secupress.me/blog/wps-child-theme-generator-v1-1-multiples-vulnerabilities/
- https://wordpress.org/plugins/wps-child-theme-generator/#developers
- https://wpvulndb.com/vulnerabilities/9470
- https://secupress.me/blog/wps-child-theme-generator-v1-1-multiples-vulnerabilities/
- https://wordpress.org/plugins/wps-child-theme-generator/#developers
- https://wpvulndb.com/vulnerabilities/9470
Get alerted when CVE-2019-15822 or the next vulnerability affects your stack