What’s Vulnerable › Vulnerabilities
CVE-2019-15846
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 35.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-09-06 · updated 2026-06-17
Description
Exim before 4.92.2 allows remote attackers to execute arbitrary code as root via a trailing backslash.
Affected products
- Debian Linux: 8.0, 9.0, 10.0
- Exim: before 4.92.2 — fixed in 4.92.2
How to fix
Upgrade to a fixed version: Exim 4.92.2. Check the vendor advisory for mitigations.
References
- http://exim.org/static/doc/security/CVE-2019-15846.txt
- http://lists.opensuse.org/opensuse-security-announce/2019-09/msg00024.html
- http://www.openwall.com/lists/oss-security/2019/09/06/2
- http://www.openwall.com/lists/oss-security/2019/09/06/4
- http://www.openwall.com/lists/oss-security/2019/09/06/5
- http://www.openwall.com/lists/oss-security/2019/09/06/6
- http://www.openwall.com/lists/oss-security/2019/09/06/8
- http://www.openwall.com/lists/oss-security/2019/09/07/1
- http://www.openwall.com/lists/oss-security/2019/09/07/2
- http://www.openwall.com/lists/oss-security/2019/09/08/1
- http://www.openwall.com/lists/oss-security/2019/09/09/1
- https://exim.org/static/doc/security/CVE-2019-15846.txt
Get alerted when CVE-2019-15846 or the next vulnerability affects your stack