What’s Vulnerable › Vulnerabilities
CVE-2019-15858
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 18.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-09-03 · updated 2026-06-17
- Weakness: CWE-306
Description
admin/includes/class.import.snippet.php in the "Woody ad snippets" plugin before 2.2.5 for WordPress allows unauthenticated options import, as demonstrated by storing an XSS payload for remote code execution.
Affected products
- Webcraftic Woody Ad Snippets: before 2.2.5 — fixed in 2.2.5
How to fix
Upgrade to a fixed version: Webcraftic Woody Ad Snippets 2.2.5. Check the vendor advisory for mitigations.
References
- https://blog.nintechnet.com/multiple-vulnerabilities-in-wordpress-woody-ad-snippets-plugin-lead-to-remote-code-execution/
- https://wpvulndb.com/vulnerabilities/9490
- https://blog.nintechnet.com/multiple-vulnerabilities-in-wordpress-woody-ad-snippets-plugin-lead-to-remote-code-execution/
- https://wpvulndb.com/vulnerabilities/9490
Get alerted when CVE-2019-15858 or the next vulnerability affects your stack