What’s Vulnerable › Vulnerabilities
CVE-2019-1591: Cisco Nexus 9000 Series Fabric Switches Application Centric Infrastructure Mode Shell Escape Vulnerability
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-03-06 · updated 2026-06-17
- Weakness: CWE-264
Description
A vulnerability in a specific CLI command implementation of Cisco Nexus 9000 Series ACI Mode Switch Software could allow an authenticated, local attacker to escape a restricted shell on an affected device. The vulnerability is due to insufficient sanitization of user-supplied input when issuing a specific CLI command with parameters on an affected device. An attacker could exploit this vulnerability by authenticating to the device CLI and issuing certain commands. A successful exploit could allow the attacker to escape the restricted shell and execute arbitrary commands with root-level privileges on the affected device. This vulnerability only affects Cisco Nexus 9000 Series ACI Mode Switches that are running a release prior to 14.0(3d).
Affected products
- Cisco NX-OS: before 14.0\(3d\) — fixed in 14.0\(3d\)
How to fix
Upgrade to a fixed version: Cisco NX-OS 14.0\(3d\). Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/107311
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20190306-aci-shell-escape
- http://www.securityfocus.com/bid/107311
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20190306-aci-shell-escape
Get alerted when CVE-2019-1591 or the next vulnerability affects your stack