What’s Vulnerable › Vulnerabilities
CVE-2019-15918
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-09-04 · updated 2026-06-17
- Weakness: CWE-125
Description
An issue was discovered in the Linux kernel before 5.0.10. SMB2_negotiate in fs/cifs/smb2pdu.c has an out-of-bounds read because data structures are incompletely updated after a change from smb30 to smb21.
Affected products
- Canonical Ubuntu Linux: 14.04, 16.04, 18.04
- Linux kernel: from 4.13.5 before 4.14.166; from 4.15 before 4.19.73; from 4.20 before 5.0.10 — fixed in 4.14.166, 4.19.73, 5.0.10
How to fix
Upgrade to a fixed version: Linux kernel 4.14.166, 4.19.73, 5.0.10. Check the vendor advisory for mitigations.
References
- https://cdn.kernel.org/pub/linux/kernel/v5.x/ChangeLog-5.0.10
- https://github.com/torvalds/linux/commit/b57a55e2200ede754e4dc9cce4ba9402544b9365
- https://security.netapp.com/advisory/ntap-20191004-0001/
- https://usn.ubuntu.com/4162-1/
- https://usn.ubuntu.com/4162-2/
- https://cdn.kernel.org/pub/linux/kernel/v5.x/ChangeLog-5.0.10
- https://github.com/torvalds/linux/commit/b57a55e2200ede754e4dc9cce4ba9402544b9365
- https://security.netapp.com/advisory/ntap-20191004-0001/
- https://usn.ubuntu.com/4162-1/
- https://usn.ubuntu.com/4162-2/
Get alerted when CVE-2019-15918 or the next vulnerability affects your stack