What’s Vulnerable › Vulnerabilities
CVE-2019-15919
- Severity: low (CVSS 3.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-09-04 · updated 2026-06-17
- Weakness: CWE-416
Description
An issue was discovered in the Linux kernel before 5.0.10. SMB2_write in fs/cifs/smb2pdu.c has a use-after-free.
Affected products
- Linux kernel: before 5.0.10 — fixed in 5.0.10
- openSUSE Leap: 15.0, 15.1
How to fix
Upgrade to a fixed version: Linux kernel 5.0.10. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2019-09/msg00064.html
- http://lists.opensuse.org/opensuse-security-announce/2019-09/msg00066.html
- https://cdn.kernel.org/pub/linux/kernel/v5.x/ChangeLog-5.0.10
- https://github.com/torvalds/linux/commit/6a3eb3360667170988f8a6477f6686242061488a
- https://security.netapp.com/advisory/ntap-20191004-0001/
- http://lists.opensuse.org/opensuse-security-announce/2019-09/msg00064.html
- http://lists.opensuse.org/opensuse-security-announce/2019-09/msg00066.html
- https://cdn.kernel.org/pub/linux/kernel/v5.x/ChangeLog-5.0.10
- https://github.com/torvalds/linux/commit/6a3eb3360667170988f8a6477f6686242061488a
- https://security.netapp.com/advisory/ntap-20191004-0001/
Get alerted when CVE-2019-15919 or the next vulnerability affects your stack