What’s Vulnerable › Vulnerabilities
CVE-2019-15926
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 5.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-09-04 · updated 2026-06-17
- Weakness: CWE-125
Description
An issue was discovered in the Linux kernel before 5.2.3. Out of bounds access exists in the functions ath6kl_wmi_pstream_timeout_event_rx and ath6kl_wmi_cac_event_rx in the file drivers/net/wireless/ath/ath6kl/wmi.c.
Affected products
- Canonical Ubuntu Linux: 16.04, 18.04, 19.10
- Debian Linux: 8.0
- Linux kernel: from 3.2 before 3.16.74; from 3.17 before 4.4.187; from 4.5 before 4.9.187; from 4.10 before 4.14.135; from 4.15 before 4.19.61; from 4.20 before 5.1.20 — fixed in 3.16.74, 4.14.135, 4.19.61, 4.4.187, 4.9.187, 5.1.20
How to fix
Upgrade to a fixed version: Linux kernel 3.16.74, 4.14.135, 4.19.61, 4.4.187. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2019-09/msg00064.html
- http://lists.opensuse.org/opensuse-security-announce/2019-09/msg00066.html
- https://cdn.kernel.org/pub/linux/kernel/v5.x/ChangeLog-5.2.3
- https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=5d6751eaff672ea77642e74e92e6c0ac7f9709ab
- https://lists.debian.org/debian-lts-announce/2019/09/msg00014.html
- https://lists.debian.org/debian-lts-announce/2019/09/msg00015.html
- https://lists.debian.org/debian-lts-announce/2019/09/msg00025.html
- https://security.netapp.com/advisory/ntap-20191004-0001/
- https://support.f5.com/csp/article/K32034450
- https://support.f5.com/csp/article/K32034450?utm_source=f5support&%3Butm_medium=RSS
- https://usn.ubuntu.com/4145-1/
- https://usn.ubuntu.com/4147-1/
Get alerted when CVE-2019-15926 or the next vulnerability affects your stack