What’s Vulnerable › Vulnerabilities
CVE-2019-15927
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-09-04 · updated 2026-06-17
- Weakness: CWE-125
Description
An issue was discovered in the Linux kernel before 4.20.2. An out-of-bounds access exists in the function build_audio_procunit in the file sound/usb/mixer.c.
Affected products
- Linux kernel: before 3.16.66; from 3.17 before 3.18.132; from 3.19 before 4.4.170; from 4.5 before 4.9.150; from 4.10 before 4.14.93; from 4.15 before 4.19.15 — fixed in 3.16.66, 3.18.132, 4.14.93, 4.19.15, 4.20.2, 4.4.170
How to fix
Upgrade to a fixed version: Linux kernel 3.16.66, 3.18.132, 4.14.93, 4.19.15. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2019-09/msg00064.html
- http://lists.opensuse.org/opensuse-security-announce/2019-09/msg00066.html
- https://cdn.kernel.org/pub/linux/kernel/v4.x/ChangeLog-4.20.2
- https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=f4351a199cc120ff9d59e06d02e8657d08e6cc46
- https://security.netapp.com/advisory/ntap-20191004-0001/
- http://lists.opensuse.org/opensuse-security-announce/2019-09/msg00064.html
- http://lists.opensuse.org/opensuse-security-announce/2019-09/msg00066.html
- https://cdn.kernel.org/pub/linux/kernel/v4.x/ChangeLog-4.20.2
- https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=f4351a199cc120ff9d59e06d02e8657d08e6cc46
- https://security.netapp.com/advisory/ntap-20191004-0001/
Get alerted when CVE-2019-15927 or the next vulnerability affects your stack