What’s Vulnerable › Vulnerabilities
CVE-2019-1593: Cisco NX-OS Software Bash Shell Role-Based Access Control Bypass Privilege Escalation Vulnerability
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-03-06 · updated 2026-06-17
- Weakness: CWE-264
Description
A vulnerability in the Bash shell implementation for Cisco NX-OS Software could allow an authenticated, local attacker to escalate their privilege level by executing commands authorized to other user roles. The attacker must authenticate with valid user credentials. The vulnerability is due to the incorrect implementation of a Bash shell command that allows role-based access control (RBAC) to be bypassed. An attacker could exploit this vulnerability by authenticating to the device and entering a crafted command at the Bash prompt. A successful exploit could allow the attacker to escalate their privilege level by executing commands that should be restricted to other roles. For example, a dev-ops user could escalate their privilege level to admin with a successful exploit of this vulnerability.
Affected products
- Cisco NX-OS: from 7.0\(3\)i5 before 7.0\(3\)i7\(4\); from 7.0\(3\)i4 before 7.0\(3\)i4\(9\); from 7.0\(3\) before 7.0\(3\)i7\(4\); from 7.0\(3\) before 7.0\(3\)f3\(5\); from 8.1 before 8.2\(3\); from 8.3 before 8.3\(1\) — fixed in 13.2\(4d\), 14.0\(1h\), 7.0\(3\)f3\(5\), 7.0\(3\)i4\(9\), 7.0\(3\)i7\(4\), 8.2\(3\)
How to fix
Upgrade to a fixed version: Cisco NX-OS 13.2\(4d\), 14.0\(1h\), 7.0\(3\)f3\(5\), 7.0\(3\)i4\(9\). Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/107324
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20190306-nx-os-bash-escal
- http://www.securityfocus.com/bid/107324
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20190306-nx-os-bash-escal
Get alerted when CVE-2019-1593 or the next vulnerability affects your stack