What’s Vulnerable › Vulnerabilities
CVE-2019-1594: Cisco NX-OS Software 802.1X Extensible Authentication Protocol over LAN Denial of Service Vulnerability
- Severity: high (CVSS 7.4 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-03-06 · updated 2026-06-17
- Weakness: CWE-264
Description
A vulnerability in the 802.1X implementation for Cisco NX-OS Software could allow an unauthenticated, adjacent attacker to cause a denial of service (DoS) condition on an affected device. The vulnerability is due to incomplete input validation of Extensible Authentication Protocol over LAN (EAPOL) frames. An attacker could exploit this vulnerability by sending a crafted EAPOL frame to an interface on the targeted device. A successful exploit could allow the attacker to cause the Layer 2 (L2) forwarding process to restart multiple times, leading to a system-level restart of the device and a DoS condition. Note: This vulnerability affects only NX-OS devices configured with 802.1X functionality. Cisco Nexus 1000V Switch for VMware vSphere devices are affected in versions prior to 5.2(1)SV3(1.4b). Nexus 3000 Series Switches are affected in versions prior to 7.0(3)I7(4). Nexus 3500 Platform Switches are affected in versions prior to 7.0(3)I7(4). Nexus 2000, 5500, 5600, and 6000 Series Switches are affected in versions prior to 7.3(5)N1(1) and 7.1(5)N1(1b). Nexus 7000 and 7700 Series Switches are affected in versions prior to 8.2(3). Nexus 9000 Series Fabric Switches in ACI Mode are affected in versions prior to 13.2(1l). Nexus 9000 Series Switches in Standalone NX-OS Mode are affected in versions prior to 7.0(3)I7(4).
Affected products
- Cisco NX-OS: before 5.2\(1\)sv3\(1.4b\); from 7.0\(3\)i7 before 7.0\(3\)i7\(4\); before 7.1\(5\)n1\(1b\); from 8.3 before 8.3\(1\); before 13.2\(1l\); from 7.2 before 7.3\(5\)n1\(1\) — fixed in 13.2\(1l\), 5.2\(1\)sv3\(1.4b\), 6.2\(20a\), 7.0\(3\)i7\(4\), 7.1\(5\)n1\(1b\), 7.3\(3\)d1\(1\)
How to fix
Upgrade to a fixed version: Cisco NX-OS 13.2\(1l\), 5.2\(1\)sv3\(1.4b\), 6.2\(20a\), 7.0\(3\)i7\(4\). Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/107325
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20190306-nx-os-lan-auth
- http://www.securityfocus.com/bid/107325
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20190306-nx-os-lan-auth
Get alerted when CVE-2019-1594 or the next vulnerability affects your stack