What’s Vulnerable › Vulnerabilities
CVE-2019-15957: Cisco Small Business Routers RV016, RV042, RV042G, RV082, RV320, and RV325 Command Injection Vulnerability
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-09-23 · updated 2026-06-17
- Weakness: CWE-20
Description
A vulnerability in the web-based management interface of certain Cisco Small Business RV Series Routers could allow an authenticated, remote attacker with administrative privileges to inject arbitrary commands into the underlying operating system. When processed, the commands will be executed with root privileges. The vulnerability is due to insufficient validation of user-supplied input. An attacker could exploit this vulnerability by providing malicious input to a specific field in the web-based management interface of an affected device. A successful exploit could allow the attacker to execute arbitrary commands on the underlying Linux operating system as the root user.
Affected products
- Cisco Rv016 Multi-Wan Vpn Firmware: before 4.2.3.10 — fixed in 4.2.3.10
- Cisco Rv042 Dual Wan Vpn: before 4.2.3.10 — fixed in 4.2.3.10
- Cisco Rv042G Dual Gigabit Wan Vpn Firmware: before 4.2.3.10 — fixed in 4.2.3.10
- Cisco Rv082 Dual Wan Vpn Router Firmware: before 4.2.3.10 — fixed in 4.2.3.10
- Cisco Rv320 Firmware: before 1.5.1.05 — fixed in 1.5.1.05
- Cisco Rv325 Firmware: before 1.5.1.05 — fixed in 1.5.1.05
How to fix
Upgrade to a fixed version: Cisco Rv016 Multi-Wan Vpn Firmware 4.2.3.10; Cisco Rv042 Dual Wan Vpn 4.2.3.10; Cisco Rv042G Dual Gigabit Wan Vpn Firmware 4.2.3.10; Cisco Rv082 Dual Wan Vpn Router Firmware 4.2.3.10; Cisco Rv320 Firmware 1.5.1.05; Cisco Rv325 Firmware 1.5.1.05. Check the vendor advisory for mitigations.
References
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20191106-sbr-cominj
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20191106-sbr-cominj
Get alerted when CVE-2019-15957 or the next vulnerability affects your stack