What’s Vulnerable › Vulnerabilities
CVE-2019-15992: Cisco Adaptive Security Appliance Software and Firepower Threat Defense Software Remote Code Execution Vulnerability
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-09-23 · updated 2026-08-11
- Weakness: CWE-119
Description
A vulnerability in the implementation of the Lua interpreter integrated in Cisco Adaptive Security Appliance (ASA) Software and Cisco Firepower Threat Defense (FTD) Software could allow an authenticated, remote attacker to execute arbitrary code with root privileges on the underlying Linux operating system of an affected device. The vulnerability is due to insufficient restrictions on the allowed Lua function calls within the context of user-supplied Lua scripts. A successful exploit could allow the attacker to trigger a heap overflow condition and execute arbitrary code with root privileges on the underlying Linux operating system of an affected device.
Affected products
- Cisco Adaptive Security Appliance: before 9.6.4.36 — fixed in 9.6.4.36
- Cisco ASA Software: from 9.7 before 9.8.4.15; from 9.9 before 9.9.2.61; from 9.10 before 9.10.1.32; from 9.12 before 9.12.3; from 9.13 before 9.13.1.4; from 9.14 before 9.14.2.7 — fixed in 9.10.1.32, 9.12.3, 9.13.1.4, 9.14.2.7, 9.15.1.4, 9.8.4.15
- Cisco Firepower Management Center: before 6.2.3.16; from 6.3.0 before 6.3.0.6; from 6.4.0 before 6.4.0.7; from 6.5.0 before 6.5.0.2 — fixed in 6.2.3.16, 6.3.0.6, 6.4.0.7, 6.5.0.2
- Cisco Firepower Threat Defense Software: all versions
How to fix
Upgrade to a fixed version: Cisco Adaptive Security Appliance 9.6.4.36; Cisco ASA Software 9.10.1.32, 9.12.3, 9.13.1.4, 9.14.2.7; Cisco Firepower Management Center 6.2.3.16, 6.3.0.6, 6.4.0.7, 6.5.0.2. Check the vendor advisory for mitigations.
References
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20191112-asa-ftd-lua-rce
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20191112-asa-ftd-lua-rce
Get alerted when CVE-2019-15992 or the next vulnerability affects your stack