What’s Vulnerable › Vulnerabilities
CVE-2019-1600: Cisco FXOS and NX-OS Software Unauthorized Directory Access Vulnerability
- Severity: medium (CVSS 4.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-03-07 · updated 2026-06-17
- Weakness: CWE-264
Description
A vulnerability in the file system permissions of Cisco FXOS Software and Cisco NX-OS Software could allow an authenticated, local attacker to access sensitive information that is stored in the file system of an affected system. The vulnerability is due to improper implementation of file system permissions. An attacker could exploit this vulnerability by accessing and modifying restricted files. A successful exploit could allow the attacker to access sensitive and critical files. Firepower 4100 Series Next-Generation Firewalls are affected in versions prior to 2.2.2.91 and 2.3.1.110. Firepower 9300 Series Next-Generation Firewalls are affected in versions prior to 2.2.2.91 and 2.3.1.110. MDS 9000 Series Multilayer Switches are affected in versions prior to 6.2(25), 8.1(1b), and 8.3(1). Nexus 3000 Series Switches are affected in versions prior to 7.0(3)I4(9) and 7.0(3)I7(4). Nexus 3500 Platform Switches are affected in versions prior to 6.0(2)A8(10) and 7.0(3)I7(4). Nexus 3600 Platform Switches are affected in versions prior to 7.0(3)F3(5). Nexus 2000, 5500, 5600, and 6000 Series Switches are affected in versions prior to 7.1(5)N1(1b) and 7.3(3)N1(1). Nexus 7000 and 7700 Series Switches are affected in versions prior to 6.2(22), 7.3(3)D1(1), and 8.2(3). Nexus 9000 Series Switches-Standalone are affected in versions prior to 7.0(3)I4(9) and 7.0(3)I7(4). Nexus 9500 R-Series Line Cards and Fabric Modules are affected in versions prior to 7.0(3)F3(5).
Affected products
- Cisco Firepower Extensible Operating System (FXOS): from 1.1 before 2.2.2.91; from 2.3 before 2.3.1.110 — fixed in 2.2.2.91, 2.3.1.110
- Cisco NX-OS: from 8.2 before 8.3\(1\); from 7.0\(3\)i5 before 7.0\(3\)i7\(4\); from 7.0\(3\) before 7.0\(3\)i7\(4\); from 7.0\(3\)f3 before 7.0\(3\)f3\(5\); from 7.2 before 7.3\(3\)n1\(1\); from 8.0 before 8.2\(3\) — fixed in 6.0\(2\)a8\(10\), 6.2\(22\), 6.2\(25\), 7.0\(3\)f3\(5\), 7.0\(3\)i4\(9\), 7.0\(3\)i7\(4\)
How to fix
Upgrade to a fixed version: Cisco Firepower Extensible Operating System (FXOS) 2.2.2.91, 2.3.1.110; Cisco NX-OS 6.0\(2\)a8\(10\), 6.2\(22\), 6.2\(25\), 7.0\(3\)f3\(5\). Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/107399
- http://www.securityfocus.com/bid/107404
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20190306-nxos-directory
- http://www.securityfocus.com/bid/107399
- http://www.securityfocus.com/bid/107404
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20190306-nxos-directory
Get alerted when CVE-2019-1600 or the next vulnerability affects your stack