What’s Vulnerable › Vulnerabilities
CVE-2019-1601: Cisco NX-OS Software Unauthorized Filesystem Access Vulnerability
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-03-08 · updated 2026-06-17
- Weakness: CWE-284
Description
A vulnerability in the filesystem permissions of Cisco NX-OS Software could allow an authenticated, local attacker to gain read and write access to a critical configuration file. The vulnerability is due to a failure to impose strict filesystem permissions on the targeted device. An attacker could exploit this vulnerability by accessing and modifying restricted files. A successful exploit could allow an attacker to use the content of this configuration file to bypass authentication and log in as any user of the device. MDS 9000 Series Multilayer Switches are affected in versions prior to 6.2(25), 8.1(1b), and 8.3(1). Nexus 3000 Series Switches are affected in versions prior to 7.0(3)I4(9) and 7.0(3)I7(4). Nexus 3500 Platform Switches are affected in versions prior to 6.0(2)A8(10) and 7.0(3)I7(4). Nexus 3600 Platform Switches are affected in versions prior to 7.0(3)F3(5). Nexus 2000, 5500, 5600, and 6000 Series Switches are affected in versions prior to 7.1(5)N1(1b) and 7.3(3)N1(1). Nexus 7000 and 7700 Series Switches are affected in versions prior to 6.2(22), 7.3(3)D1(1), and 8.2(3). Nexus 9000 Series Switches-Standalone are affected in versions prior to 7.0(3)I4(9) and 7.0(3)I7(4). Nexus 9500 R-Series Line Cards and Fabric Modules are affected in versions prior to 7.0(3)F3(5).
Affected products
- Cisco NX-OS: from 8.2 before 8.3\(1\); from 7.0\(3\) before 7.0\(3\)i7\(4\); from 7.0\(3\)i5 before 7.0\(3\)i7\(4\); from 7.0\(3\)f3 before 7.0\(3\)f3\(5\); from 7.0\(3\)f1 before 7.0\(3\)f3\(5\); from 7.3 before 8.1\(1b\) — fixed in 6.0\(2\)a8\(10\), 6.2\(22\), 6.2\(25\), 7.0\(3\)f3\(5\), 7.0\(3\)i4\(9\), 7.0\(3\)i7\(4\)
How to fix
Upgrade to a fixed version: Cisco NX-OS 6.0\(2\)a8\(10\), 6.2\(22\), 6.2\(25\), 7.0\(3\)f3\(5\). Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/107404
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20190306-nxos-file-access
- http://www.securityfocus.com/bid/107404
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20190306-nxos-file-access
Get alerted when CVE-2019-1601 or the next vulnerability affects your stack