What’s Vulnerable › Vulnerabilities
CVE-2019-16011: Cisco IOS XE SD-WAN Software Command Injection Vulnerability
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-04-29 · updated 2026-06-17
- Weakness: CWE-77
Description
A vulnerability in the CLI of Cisco IOS XE SD-WAN Software could allow an authenticated, local attacker to inject arbitrary commands that are executed with root privileges. The vulnerability is due to insufficient input validation. An attacker could exploit this vulnerability by authenticating to the device and submitting crafted input to the CLI utility. The attacker must be authenticated to access the CLI utility. A successful exploit could allow the attacker to execute commands with root privileges.
Affected products
- Cisco IOS XE: from 16.12 before 17.2.1r; 16.10.2, 16.11, 16.9, 16.10, 17.3 — fixed in 17.2.1r
How to fix
Upgrade to a fixed version: Cisco IOS XE 17.2.1r. Check the vendor advisory for mitigations.
References
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-xesdwcinj-AcQ5MxCn
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-xesdwcinj-AcQ5MxCn
Get alerted when CVE-2019-16011 or the next vulnerability affects your stack