What’s Vulnerable › Vulnerabilities
CVE-2019-16015: Cisco Data Center Analytics Framework Cross-Site Scripting Vulnerability
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-01-26 · updated 2026-06-17
- Weakness: CWE-79
Description
A vulnerability in the web-based management interface of the Cisco Data Center Analytics Framework application could allow an unauthenticated, remote attacker to conduct a reflected cross-site scripting (XSS) attack against a user of the interface of an affected system. The vulnerability is due to insufficient validation of user-supplied input by the web-based management interface of the affected software. An attacker could exploit this vulnerability by persuading a user of the interface to click a malicious link. A successful exploit could allow the attacker to execute arbitrary script code in the context of the interface or allow the attacker to access sensitive, browser-based information on the affected system.
Affected products
- Cisco Data Center Analytics Framework: before 8.3.7.5.4 — fixed in 8.3.7.5.4
How to fix
Upgrade to a fixed version: Cisco Data Center Analytics Framework 8.3.7.5.4. Check the vendor advisory for mitigations.
References
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20200108-dcaf-xss
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20200108-dcaf-xss
Get alerted when CVE-2019-16015 or the next vulnerability affects your stack