What’s Vulnerable › Vulnerabilities
CVE-2019-1603: Cisco NX-OS Software Privilege Escalation Vulnerability
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-03-08 · updated 2026-06-17
- Weakness: CWE-285
Description
A vulnerability in the CLI of Cisco NX-OS Software could allow an authenticated, local attacker to escalate lower-level privileges to the administrator level. The vulnerability is due to insufficient authorization enforcement. An attacker could exploit this vulnerability by authenticating to the targeted device and executing commands that could lead to elevated privileges. A successful exploit could allow an attacker to make configuration changes to the system as administrator. Nexus 3000 Series Switches are affected in versions prior to 7.0(3)I7(4). Nexus 3500 Platform Switches are affected in versions prior to 7.0(3)I7(4). Nexus 3600 Platform Switches are affected in versions prior to 7.0(3)F3(5). Nexus 9000 Series Switches-Standalone are affected in versions prior to 7.0(3)I7(4). Nexus 9500 R-Series Line Cards and Fabric Modules are affected in versions prior to 7.0(3)F3(5).
Affected products
- Cisco NX-OS: before 7.0\(3\)i7\(4\); before 7.0\(3\)f3\(5\) — fixed in 7.0\(3\)f3\(5\), 7.0\(3\)i7\(4\)
How to fix
Upgrade to a fixed version: Cisco NX-OS 7.0\(3\)f3\(5\), 7.0\(3\)i7\(4\). Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/107328
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20190306-nxos-privesc
- http://www.securityfocus.com/bid/107328
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20190306-nxos-privesc
Get alerted when CVE-2019-1603 or the next vulnerability affects your stack