What’s Vulnerable › Vulnerabilities
CVE-2019-1604: Cisco NX-OS Software Privilege Escalation Vulnerability
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-03-08 · updated 2026-06-17
- Weakness: CWE-285
Description
A vulnerability in the user account management interface of Cisco NX-OS Software could allow an authenticated, local attacker to gain elevated privileges on an affected device. The vulnerability is due to an incorrect authorization check of user accounts and their associated Group ID (GID). An attacker could exploit this vulnerability by taking advantage of a logic error that will permit the use of higher privileged commands than what is necessarily assigned. A successful exploit could allow an attacker to execute commands with elevated privileges on the underlying Linux shell of an affected device. Nexus 7000 and 7700 Series Switches are affected in versions prior to 6.2(22), 8.2(3), and 8.3(2). Nexus 3000 Series Switches are affected in versions prior to 7.0(3)I7(4). Nexus 3500 Platform Switches are affected in versions prior to 7.0(3)I7(4). Nexus 3600 Platform Switches are affected in versions prior to 7.0(3)F3(5). Nexus 9000 Series Switches-Standalone are affected in versions prior to 7.0(3)I7(4). Nexus 9500 R-Series Line Cards and Fabric Modules are affected in versions prior to 7.0(3)F3(5).
Affected products
- Cisco NX-OS: before 7.0\(3\)i7\(4\); before 7.0\(3\)f3\(5\); from 8.2\(3\) (excl.) before 8.3\(2\); from 6.22\(22\) (excl.) before 8.2\(3\); before 6.2\(22\) — fixed in 6.2\(22\), 7.0\(3\)f3\(5\), 7.0\(3\)i7\(4\), 8.2\(3\), 8.3\(2\)
How to fix
Upgrade to a fixed version: Cisco NX-OS 6.2\(22\), 7.0\(3\)f3\(5\), 7.0\(3\)i7\(4\), 8.2\(3\). Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/107323
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20190306-nxos-privesca
- http://www.securityfocus.com/bid/107323
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20190306-nxos-privesca
Get alerted when CVE-2019-1604 or the next vulnerability affects your stack