What’s Vulnerable › Vulnerabilities
CVE-2019-1605: Cisco NX-OS Software NX-API Arbitrary Code Execution Vulnerability
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-03-08 · updated 2026-06-17
- Weakness: CWE-20
Description
A vulnerability in the NX-API feature of Cisco NX-OS Software could allow an authenticated, local attacker to execute arbitrary code as root. The vulnerability is due to incorrect input validation in the NX-API feature. An attacker could exploit this vulnerability by sending a crafted HTTP or HTTPS request to an internal service on an affected device that has the NX-API feature enabled. A successful exploit could allow the attacker to cause a buffer overflow and execute arbitrary code as root. Note: The NX-API feature is disabled by default. MDS 9000 Series Multilayer Switches are affected in versions prior to 8.1(1). Nexus 3000 Series Switches are affected in versions prior to 7.0(3)I4(8) and 7.0(3)I7(1). Nexus 3500 Platform Switches are affected in versions prior to 6.0(2)A8(8). Nexus 3600 Platform Switches are affected in versions prior to 7.0(3)F3(5). Nexus 2000, 5500, 5600, and 6000 Series Switches are affected in versions prior to 7.3(2)N1(1). Nexus 7000 and 7700 Series Switches are affected in versions prior to 7.3(3)D1(1). Nexus 9000 Series Switches in Standalone NX-OS Mode are affected in versions prior to 7.0(3)I4(8) and 7.0(3)I7(1). Nexus 9500 R-Series Line Cards and Fabric Modules are affected in versions prior to 7.0(3)F3(5).
Affected products
- Cisco NX-OS: from 7.3 before 8.1\(1\); before 6.0\(2\)a8\(8\); from 7.0\(3\)i5 before 7.0\(3\)i7\(1\); from 7.0\(3\)f3 before 7.0\(3\)f3\(5\); from 7.2 before 7.3\(3\)d1\(1\); before 7.0\(3\)i4\(8\) — fixed in 6.0\(2\)a8\(8\), 7.0\(3\)f3\(5\), 7.0\(3\)i4\(8\), 7.0\(3\)i7\(1\), 7.3\(2\)n1\(1\), 7.3\(3\)d1\(1\)
How to fix
Upgrade to a fixed version: Cisco NX-OS 6.0\(2\)a8\(8\), 7.0\(3\)f3\(5\), 7.0\(3\)i4\(8\), 7.0\(3\)i7\(1\). Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/107313
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20190306-nxos-api-ex
- http://www.securityfocus.com/bid/107313
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20190306-nxos-api-ex
Get alerted when CVE-2019-1605 or the next vulnerability affects your stack