What’s Vulnerable › Vulnerabilities
CVE-2019-1606: Cisco NX-OS Software CLI Command Injection Vulnerability (CVE-2019-1606)
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-03-08 · updated 2026-06-17
- Weakness: CWE-77
Description
A vulnerability in the CLI of Cisco NX-OS Software could allow an authenticated, local attacker to execute arbitrary commands on the underlying operating system of an affected device. The vulnerability is due to insufficient validation of arguments passed to certain CLI commands. An attacker could exploit this vulnerability by including malicious input as the argument of an affected command. A successful exploit could allow the attacker to execute arbitrary commands on the underlying operating system with elevated privileges. An attacker would need valid user credentials to exploit this vulnerability. Nexus 3000, 3500, and Nexus 9000 Series Switches in Standalone NX-OS Mode are affected in versions prior to 7.0(3)I7(4).
Affected products
- Cisco NX-OS: from 7.0\(3\)i7 before 7.0\(3\)i7\(4\); from 7.0\(3\) before 7.0\(3\)i7\(4\) — fixed in 7.0\(3\)i7\(4\)
How to fix
Upgrade to a fixed version: Cisco NX-OS 7.0\(3\)i7\(4\). Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/107345
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20190306-nxos-cmdinj-1606
- http://www.securityfocus.com/bid/107345
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20190306-nxos-cmdinj-1606
Get alerted when CVE-2019-1606 or the next vulnerability affects your stack