What’s Vulnerable › Vulnerabilities
CVE-2019-1611: Cisco FXOS and NX-OS Software CLI Command Injection Vulnerability (CVE-2019-1611)
- Severity: medium (CVSS 6.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-03-11 · updated 2026-06-17
- Weakness: CWE-77
Description
A vulnerability in the CLI of Cisco NX-OS Software and Cisco FXOS Software could allow an authenticated, local attacker to execute arbitrary commands on the underlying operating system of an affected device. The vulnerability is due to insufficient validation of arguments passed to certain CLI commands. An attacker could exploit this vulnerability by including malicious input as the argument of an affected command. A successful exploit could allow the attacker to execute arbitrary commands on the underlying operating system with elevated privileges. An attacker would need valid administrator credentials to exploit this vulnerability. Firepower 4100 Series Next-Generation Firewalls are affected running software versions prior to 2.2.2.91, 2.3.1.110, and 2.4.1.222. Firepower 9300 Security Appliance are affected running software versions prior to 2.2.2.91, 2.3.1.110, and 2.4.1.222. MDS 9000 Series Multilayer Switches are affected running software versions prior to 6.2(25) and 8.3(1). Nexus 3000 Series Switches are affected running software versions prior to 7.0(3)I4(9) and 7.0(3)I7(5). Nexus 3500 Platform Switches are affected running software versions prior to 7.0(3)I7(5). Nexus 3600 Platform Switches are affected running software versions prior to 7.0(3)F3(5). Nexus 2000, 5500, 5600, and 6000 Series Switches are affected running software versions prior to 7.1(5)N1(1b) and 7.3(4)N1(1). Nexus 7000 and 7700 Series Switches are affected running software versions prior to 6.2(22), 7.3(3)D1(1), 8.2(3). Nexus 9000 Series Switches in Standalone NX-OS Mode are affected running software versions prior to 7.0(3)I4(9) and 7.0(3)I7(5). Nexus 9500 R-Series Line Cards and Fabric Modules are affected running software versions prior to 7.0(3)F3(5).
Affected products
- Cisco Fx-Os: from 2.4 before 2.4.1.222; from 2.3 before 2.3.1.110; from 1.1 before 2.2.2.91 — fixed in 2.2.2.91, 2.3.1.110, 2.4.1.222
- Cisco NX-OS: from 7.3 before 8.3\(1\); from 5.2 before 6.2\(25\); from 7.0\(3\)i5 before 7.0\(3\)i7\(5\); before 7.0\(3\)i4\(9\); from 7.0\(3\) before 7.0\(3\)i7\(5\); from 7.2 before 7.3\(4\)n1\(1\) — fixed in 6.2\(22\), 6.2\(25\), 7.0\(3\)f3\(5\), 7.0\(3\)i4\(9\), 7.0\(3\)i7\(5\), 7.1\(5\)n1\(1b\)
How to fix
Upgrade to a fixed version: Cisco Fx-Os 2.2.2.91, 2.3.1.110, 2.4.1.222; Cisco NX-OS 6.2\(22\), 6.2\(25\), 7.0\(3\)f3\(5\), 7.0\(3\)i4\(9\). Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/107381
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20190306-nxos-cmdinj-1611
- http://www.securityfocus.com/bid/107381
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20190306-nxos-cmdinj-1611
Get alerted when CVE-2019-1611 or the next vulnerability affects your stack